# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<pre>((?:[^\n]+?))</pre>"
test_str = "<pre>one</pre><p><b>two</b></p>\\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>"
subst = "<p>$1</p>\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.