import Foundation
let pattern = #"<pre>((?:[^\n]+?))</pre>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<pre>one</pre><p><b>two</b></p>\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<p>$1</p>\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)