$re = '/<pre>((?:[^\n]+?))</pre>/';
$str = '<pre>one</pre><p><b>two</b></p>\\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>';
$subst = "<p>$1</p>\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;