re = /<pre>((?:[^\n]+?))<\/pre>/
str = '<pre>one</pre><p><b>two</b></p>\\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>'
subst = '<p>$1</p>\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result