const regex = new RegExp('<pre>((?:[^\\n]+?))</pre>', 'g')
const str = `<pre>one</pre><p><b>two</b></p>\\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>`;
const subst = `<p>$1</p>\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);