# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/__ent_0*(\d+)_/<ph$1\/>/gm;t' <<< "__ent_00000_Bye bye StackOverflow! __ent_00001_"