use strict;
my $str = '__ent_00000_Bye bye StackOverflow! __ent_00001_';
my $regex = qr/__ent_0*(\d+)_/mp;
my $subst = '<ph$1/>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";