package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)__ent_0*(\d+)_`)
var str = `__ent_00000_Bye bye StackOverflow! __ent_00001_`
var substitution = "<ph$1/>"
fmt.Println(re.ReplaceAllString(str, substitution))
}