const regex = /__ent_0*(\d+)_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('__ent_0*(\\d+)_', 'gm')
const str = `__ent_00000_Bye bye StackOverflow! __ent_00001_`;
const subst = `<ph$1/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);