// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)__ent_0*(\d+)_").unwrap();
let string = "__ent_00000_Bye bye StackOverflow! __ent_00001_";
let substitution = "<ph$1/>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}