import Foundation
let pattern = #"__ent_0*(\d+)_"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"__ent_00000_Bye bye StackOverflow! __ent_00001_"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<ph$1/>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)