# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)(?<=\s-\s)\w+\s+(.*)/\1\2/gmi;t' <<< "Dámské mikinošaty bez potisku - černé Černá M - volný střih
Dámské mikinošaty bez potisku - černé Černá XS - volný střih
Taška Happy Nature Příroda - černá Černá Univerzální
Čepice Západ - šedá Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - růžová Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - hořčicové Hořčicová - okrově žlutá L"