re = /(.*?)(?<=\s-\s)\w+\s+(.*)/mi
str = 'Dámské mikinošaty bez potisku - černé Černá M - volný střih
Dámské mikinošaty bez potisku - černé Černá XS - volný střih
Taška Happy Nature Příroda - černá Černá Univerzální
Čepice Západ - šedá Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - růžová Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - hořčicové Hořčicová - okrově žlutá L'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result