const regex = new RegExp('(.*?)(?<=\\s-\\s)\\w+\\s+(.*)', 'gmi')
const str = `Dámské mikinošaty bez potisku - černé Černá M - volný střih
Dámské mikinošaty bez potisku - černé Černá XS - volný střih
Taška Happy Nature Příroda - černá Černá Univerzální
Čepice Západ - šedá Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - růžová Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - hořčicové Hořčicová - okrově žlutá L`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);