# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)(?<=\s-\s)\w+\s+(.*)"
test_str = ("Dámské mikinošaty bez potisku - černé Černá M - volný střih\n"
"Dámské mikinošaty bez potisku - černé Černá XS - volný střih\n"
"Taška Happy Nature Příroda - černá Černá Univerzální\n"
"Čepice Západ - šedá Šedá Univerzální\n"
"Dětská mikina bez kapuce Never stop dreaming - růžová Karmínově růžová 9 - 11 let\n"
"Dámské tričko Štěstí - hořčicové Hořčicová - okrově žlutá L")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.