#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(.*?)(?<=\s-\s)\w+\s+(.*)"
Local $sString = "Dámské mikinošaty bez potisku - černé Černá M - volný střih" & @CRLF & _
"Dámské mikinošaty bez potisku - černé Černá XS - volný střih" & @CRLF & _
"Taška Happy Nature Příroda - černá Černá Univerzální" & @CRLF & _
"Čepice Západ - šedá Šedá Univerzální" & @CRLF & _
"Dětská mikina bez kapuce Never stop dreaming - růžová Karmínově růžová 9 - 11 let" & @CRLF & _
"Dámské tričko Štěstí - hořčicové Hořčicová - okrově žlutá L"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)