import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(?<=\\s-\\s)\\w+\\s+(.*)";
final String string = "Dámské mikinošaty bez potisku - černé Černá M - volný střih\n"
+ "Dámské mikinošaty bez potisku - černé Černá XS - volný střih\n"
+ "Taška Happy Nature Příroda - černá Černá Univerzální\n"
+ "Čepice Západ - šedá Šedá Univerzální\n"
+ "Dětská mikina bez kapuce Never stop dreaming - růžová Karmínově růžová 9 - 11 let\n"
+ "Dámské tričko Štěstí - hořčicové Hořčicová - okrově žlutá L";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}