use strict;
my $str = 'Dámské mikinošaty bez potisku - černé Černá M - volný střih
Dámské mikinošaty bez potisku - černé Černá XS - volný střih
Taška Happy Nature Příroda - černá Černá Univerzální
Čepice Západ - šedá Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - růžová Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - hořčicové Hořčicová - okrově žlutá L';
my $regex = qr/(.*?)(?<=\s-\s)\w+\s+(.*)/mip;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";