using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(?<=\s-\s)\w+\s+(.*)";
string substitution = @"\1\2";
string input = @"Dámské mikinošaty bez potisku - černé Černá M - volný střih
Dámské mikinošaty bez potisku - černé Černá XS - volný střih
Taška Happy Nature Příroda - černá Černá Univerzální
Čepice Západ - šedá Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - růžová Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - hořčicové Hořčicová - okrově žlutá L";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}