#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\"[^\"]*\"|'[^']*')(*SKIP)(*F)|\b(and|or)\b"
Local $sString = "Industry ='Education' or Industry ="Energy" or Industry = 'Financial or Bank' or Industry = 'Hospitality' or Industry = "Food and Beverage" and Industry = 'Utilities'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")