import Foundation
let pattern = #"(?:\"[^\"]*\"|'[^']*')(*SKIP)(*F)|\b(and|or)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Industry ='Education' or Industry ="Energy" or Industry = 'Financial or Bank' or Industry = 'Hospitality' or Industry = "Food and Beverage" and Industry = 'Utilities'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)