const regex = /(?:\"[^\"]*\"|'[^']*')(*SKIP)(*F)|\b(and|or)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\"[^\\"]*\\"|\'[^\']*\')(*SKIP)(*F)|\\b(and|or)\\b', 'g')
const str = `Industry ='Education' or Industry ="Energy" or Industry = 'Financial or Bank' or Industry = 'Hospitality' or Industry = "Food and Beverage" and Industry = 'Utilities'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}