re = /(?:\"[^\"]*\"|'[^']*')(*SKIP)(*F)|\b(and|or)\b/
str = 'Industry =\'Education\' or Industry ="Energy" or Industry = \'Financial or Bank\' or Industry = \'Hospitality\' or Industry = "Food and Beverage" and Industry = \'Utilities\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end