use strict;
my $str = 'Industry =\'Education\' or Industry ="Energy" or Industry = \'Financial or Bank\' or Industry = \'Hospitality\' or Industry = "Food and Beverage" and Industry = \'Utilities\'';
my $regex = qr/(?:\"[^\"]*\"|'[^']*')(*SKIP)(*F)|\b(and|or)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}