package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\"[^\"]*\"|'[^']*')(*SKIP)(*F)|\b(and|or)\b`)
var str = `Industry ='Education' or Industry ="Energy" or Industry = 'Financial or Bank' or Industry = 'Hospitality' or Industry = "Food and Beverage" and Industry = 'Utilities'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}