using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\""[^\""]*\""|'[^']*')(*SKIP)(*F)|\b(and|or)\b";
string input = @"Industry ='Education' or Industry =""Energy"" or Industry = 'Financial or Bank' or Industry = 'Hospitality' or Industry = ""Food and Beverage"" and Industry = 'Utilities'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}