# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\bnot|n't|\G(?!\A))\s+\K(\w+)\b/not_\1/g;t' <<< "They didn't sell the company, and it went bankrupt"