#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\bnot|n't|\G(?!\A))\s+\K(\w+)\b"
Local $sString = "They didn't sell the company, and it went bankrupt"
Local $sSubst = "not_\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)