const regex = /(?:\bnot|n't|\G(?!\A))\s+\K(\w+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\bnot|n\'t|\\G(?!\\A))\\s+\\K(\\w+)\\b', 'g')
const str = `They didn't sell the company, and it went bankrupt`;
const subst = `not_\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);