import Foundation
let pattern = #"(?:\bnot|n't|\G(?!\A))\s+\K(\w+)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"They didn't sell the company, and it went bankrupt"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"not_\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)