re = /(?:\bnot|n't|\G(?!\A))\s+\K(\w+)\b/
str = 'They didn\'t sell the company, and it went bankrupt'
subst = 'not_\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result