$re = '/(?:\bnot|n\'t|\G(?!\A))\s+\K(\w+)\b/';
$str = 'They didn\'t sell the company, and it went bankrupt';
$subst = "not_\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;