using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\bnot|n't|\G(?!\A))\s+\K(\w+)\b";
string substitution = @"not_\1";
string input = @"They didn't sell the company, and it went bankrupt";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}