use strict;
my $str = 'They didn\'t sell the company, and it went bankrupt';
my $regex = qr/(?:\bnot|n't|\G(?!\A))\s+\K(\w+)\b/p;
my $subst = 'not_\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";