#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[\[:fr:(?P<lien>[^:|[{}\n\]\|]+)\|(?P=lien)\]\]"
Local $sString = "[[:fr:Mille_Miglia_1932|Mille Miglia]]" & @CRLF & _
"[[:fr:wikt:demi-produit|demi-produit]] :" & @CRLF & _
"Amours Gauquié Pont Alexandre III Paris.jpg|Lampadaire "Ronde des Amours" de [[:fr:Henri Désiré Gauquié|Henri Désiré Gauquié]], [[Pont Alexandre III]] Kiosque..." & @CRLF & _
"" & @CRLF & _
"- * [[:fr:Jean Dewasne|Jean Dewasne]]" & @CRLF & _
""
Local $sSubst = "[[\g<1>]]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)