$re = '/\[\[:fr:(?P<lien>[^:|[{}\n\]\|]+)\|(?P=lien)\]\]/m';
$str = '[[:fr:Mille_Miglia_1932|Mille Miglia]]
[[:fr:wikt:demi-produit|demi-produit]] :
Amours Gauquié Pont Alexandre III Paris.jpg|Lampadaire "Ronde des Amours" de [[:fr:Henri Désiré Gauquié|Henri Désiré Gauquié]], [[Pont Alexandre III]] Kiosque...
- * [[:fr:Jean Dewasne|Jean Dewasne]]
';
$subst = "[[\g<1>]]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;