import re
regex = re.compile(r"\[\[:fr:(?P<lien>[^:|[{}\n\]\|]+)\|(?P=lien)\]\]", flags=re.MULTILINE)
test_str = ("[[:fr:Mille_Miglia_1932|Mille Miglia]]\n"
"[[:fr:wikt:demi-produit|demi-produit]] :\n"
"Amours Gauquié Pont Alexandre III Paris.jpg|Lampadaire \"Ronde des Amours\" de [[:fr:Henri Désiré Gauquié|Henri Désiré Gauquié]], [[Pont Alexandre III]] Kiosque...\n\n"
"- * [[:fr:Jean Dewasne|Jean Dewasne]]\n")
subst = "[[\\g<1>]]"
result = regex.sub(subst, test_str)
if result:
print(result)