using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[:fr:(?P<lien>[^:|[{}\n\]\|]+)\|(?P=lien)\]\]";
string substitution = @"[[\g<1>]]";
string input = @"[[:fr:Mille_Miglia_1932|Mille Miglia]]
[[:fr:wikt:demi-produit|demi-produit]] :
Amours Gauquié Pont Alexandre III Paris.jpg|Lampadaire ""Ronde des Amours"" de [[:fr:Henri Désiré Gauquié|Henri Désiré Gauquié]], [[Pont Alexandre III]] Kiosque...
- * [[:fr:Jean Dewasne|Jean Dewasne]]
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}