import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[:fr:(?P<lien>[^:|[\\{\\}\\n\\]\\|]+)\\|(?P=lien)\\]\\]";
final String string = "[[:fr:Mille_Miglia_1932|Mille Miglia]]\n"
+ "[[:fr:wikt:demi-produit|demi-produit]] :\n"
+ "Amours Gauquié Pont Alexandre III Paris.jpg|Lampadaire \"Ronde des Amours\" de [[:fr:Henri Désiré Gauquié|Henri Désiré Gauquié]], [[Pont Alexandre III]] Kiosque...\n\n"
+ "- * [[:fr:Jean Dewasne|Jean Dewasne]]\n";
final String subst = "[[\\g<1>]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}