#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(http://example.com/images/.*?/.*?/.*?).png"
Local $sString = "http://example.com/images/XX/YY/filename.png"
Local $sSubst = "$1.jpg"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)