using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http://example.com/images/.*?/.*?/.*?).png";
string substitution = @"$1.jpg";
string input = @"http://example.com/images/XX/YY/filename.png";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}