const regex = new RegExp('(http://example.com/images/.*?/.*?/.*?).png', 'g')
const str = `http://example.com/images/XX/YY/filename.png`;
const subst = `$1.jpg`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);