package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http://example.com/images/.*?/.*?/.*?).png`)
var str = `http://example.com/images/XX/YY/filename.png`
var substitution = "$1.jpg"
fmt.Println(re.ReplaceAllString(str, substitution))
}