// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http://example.com/images/.*?/.*?/.*?).png").unwrap();
let string = "http://example.com/images/XX/YY/filename.png";
let substitution = "$1.jpg";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}