import Foundation
let pattern = #"(http://example.com/images/.*?/.*?/.*?).png"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://example.com/images/XX/YY/filename.png"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.jpg"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)