re = /(http:\/\/example.com\/images\/.*?\/.*?\/.*?).png/
str = 'http://example.com/images/XX/YY/filename.png'
subst = '$1.jpg'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result