#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""unavailablePosts"\s*:\s*\[([\s\S]*?)\],"
Local $sString = ""unavailablePosts": ["AA", "BB"],"
Local $sSubst = ""unavailablePosts": "XXX","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)