$re = '/"unavailablePosts"\s*:\s*\[([\s\S]*?)\],/';
$str = '"unavailablePosts": ["AA", "BB"],';
$subst = "\"unavailablePosts\": \"XXX\",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;