// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""unavailablePosts"\s*:\s*\[([\s\S]*?)\],"#).unwrap();
let string = "\"unavailablePosts\": [\"AA\", \"BB\"],";
let substitution = "\"unavailablePosts\": \"XXX\",";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}