import Foundation
let pattern = #""unavailablePosts"\s*:\s*\[([\s\S]*?)\],"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""unavailablePosts": ["AA", "BB"],"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""unavailablePosts": "XXX","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)